Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007097 [Squeak] Kernel minor always 06-16-08 14:38 02-06-11 23:48
Reporter brp View Status public  
Assigned To nicolas cellier
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version trunk Product Version 3.9
  Product Build
Summary 0007097: Year >> previous returns two years prior in leap years
Description Year >> #previous fails for any leap year.

E.g. (Year year: 2008) previous. "Answers Year(2006).

The problem is isolated to the inherited method Timespan >> #previous.
The resolution is to implement Year >> #previous.

Attached is the recommended fix and a new YearTest test case.


Steps To Reproduce
Additional Information Brent Pinkney is the maintainer of the Chronology classes.
Brent wrote and tested this fix.
Attached Files  previousInLeapYearFix-brp.1.cs.gz [^] (466 bytes) 06-16-08 14:38

- Relationships

- Notes
(0013842 - 56 - 56 - 56 - 56 - 56 - 56)
nicolas cellier
08-22-10 15:07

This appears to be resolved in trunk, don't know when...
 

- Issue History
Date Modified Username Field Change
06-16-08 14:38 brp New Issue
06-16-08 14:38 brp File Added: previousInLeapYearFix-brp.1.cs.gz
06-17-08 00:23 lewis Issue Monitored: lewis
08-22-10 15:07 nicolas cellier Status new => resolved
08-22-10 15:07 nicolas cellier Fixed in Version  => trunk
08-22-10 15:07 nicolas cellier Resolution open => fixed
08-22-10 15:07 nicolas cellier Assigned To  => nicolas cellier
08-22-10 15:07 nicolas cellier Note Added: 0013842
02-06-11 23:48 leves Status resolved => closed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
43 total queries executed.
33 unique queries executed.
Powered by Mantis Bugtracker