Mantis Bugtracker

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007385 [Squeak] System major always 08-18-09 14:39 08-18-09 14:39
Reporter gsa View Status public  
Assigned To
Priority normal Resolution open Platform
Status new   OS
Projection none   OS Version
ETA none Fixed in Version Product Version 3.10.2
  Product Build
Summary 0007385: Socket(Object)>>primitiveFailed
Description I'm trying to start an image in the form "completepath/vmname
completpath/imagename completpath/startupscript arg1" were arg1 is a port number to start WAKom.

As not worked headless I tried showing the main Squeak window and I
get the subject error with not much more info.

I'm using "Squeak" with a 3.10.2 image running on Mac
OS X Server 10.5.5.

I also tried on a linux box with a unix vm (Squeak-3.10-6.i686-pc-linux-gnu.tar.gz) and got the same error at socket level (Socket>>listenOn: /

Trying a bit more on Linux and debugging, the error show:

Socket(Object)>>doesNotUnderstand: #waitForConnectionUntil:

On the debugger, on TcpListener I can see that port is ok, and the
handler is "seaside [running] port: 8888", the port that I passed,
but.....the image don't respond on such port and the debugger get fired.

My script only read the port, as follow:

| port |
port := SmalltalkImage current getSystemAttribute: 3.
WAKom stop.
WAKom startOn: port.

The script will be more complex in the future, now is at this way only
to try if works.
Steps To Reproduce
Additional Information
Attached Files

- Relationships

There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
08-18-09 14:39 gsa New Issue
08-18-09 14:40 gsa Issue Monitored: gsa

Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
29 total queries executed.
24 unique queries executed.
Powered by Mantis Bugtracker