Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007438 [Squeak] Morphic minor always 01-11-10 07:31 04-18-10 21:57
Reporter wiz View Status public  
Assigned To laza
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version trunk Product Version trunk
  Product Build
Summary 0007438: In sq 8836 Need to remove unimplemented calls in AlignmentMorphBob1
Description Two methods are sending #...in: where they mean #...inMorph:

This is responsible for 2 of the 199 unimplemented calls in sq8836
Steps To Reproduce
Additional Information uploaded changeset with corrected calls.
Attached Files  UnimpRemovalBob1-wiz.1.cs [^] (1,488 bytes) 01-11-10 07:31

- Relationships

- Notes
(0013461 - 311 - 335 - 335 - 335 - 335 - 335)
wiz
01-11-10 07:38

The unimplemented calls are hidden behind a predicate that AFAICT will is never true. Other than that they seem to just send to super. So the true fix might be just removing these methods allowing inheritance to handle them.

I didn't opt for that because proving that right would take further study.

-Jer
 
(0013533 - 45 - 45 - 45 - 45 - 45 - 45)
laza
03-09-10 16:10

Fixed in Trun 9652 with MorphicExtras-laza.78
 

- Issue History
Date Modified Username Field Change
01-11-10 07:31 wiz New Issue
01-11-10 07:31 wiz File Added: UnimpRemovalBob1-wiz.1.cs
01-11-10 07:38 wiz Note Added: 0013461
03-09-10 16:04 laza Assigned To  => laza
03-09-10 16:04 laza Status new => confirmed
03-09-10 16:10 laza Status confirmed => resolved
03-09-10 16:10 laza Fixed in Version  => trunk
03-09-10 16:10 laza Resolution open => fixed
03-09-10 16:10 laza Note Added: 0013533
04-18-10 21:57 andreas Status resolved => closed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
45 total queries executed.
34 unique queries executed.
Powered by Mantis Bugtracker