Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007556 [Squeak] Morphic trivial always 08-22-10 09:26 02-06-11 23:48
Reporter daddym View Status public  
Assigned To leves
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version trunk Product Version 4.1
  Product Build
Summary 0007556: StringMorph raise "MessageNotUnderstood" during attempt to change font by dialog chooser.
Description s := StringMorph new openInHand.
s changeFont.
Try to Ok or Cancel a chooser and gotcha.

Steps To Reproduce
Additional Information From my point of view the problem is that in StringMorph>>changeFont last two lines are completely useless. We already make a choice via events and do not need return result from "chooser".
This lines are from Morphic-ar.164

PS: In Pharo 1.1 this still working fine due to "chooser" is a FontChooser, not a PluggableSystemWindow.
Attached Files

- Relationships

- Notes
(0013844 - 28 - 28 - 28 - 28 - 28 - 28)
leves
08-22-10 23:03

Fixed in Morphic-ul.461.mcz.
 

- Issue History
Date Modified Username Field Change
08-22-10 09:26 daddym New Issue
08-22-10 23:03 leves Status new => resolved
08-22-10 23:03 leves Fixed in Version  => trunk
08-22-10 23:03 leves Resolution open => fixed
08-22-10 23:03 leves Assigned To  => leves
08-22-10 23:03 leves Note Added: 0013844
02-06-11 23:48 leves Status resolved => closed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
37 total queries executed.
31 unique queries executed.
Powered by Mantis Bugtracker