Mantis - Croquet
Viewing Issue Advanced Details
390 Jasmine minor always 10-14-04 19:32 05-30-05 13:42
shinthegin  
 
normal  
feedback  
open  
none    
none  
0000390: Walkback on connection attempt
After filling in the TConnectionDialog and pressing the "Connect" button, after a while I get the sound and a walkback saying: "Error: target is nil." while evaluating TeaMessage->execute.
Running on:
Athlon-1800+,512Mb,ATI-8500LE, Linux 2.4.27, XFree86 radeon driver.
 SqueakDebug.log [^] (499 bytes) 10-20-04 19:32
 jasmine.PNG [^] (420,494 bytes) 10-20-04 19:34
 LinuxConnectionFIX-dgd.2.cs.gz [^] (873 bytes) 05-30-05 13:40

Notes
(0000468)
andreas   
10-19-04 03:10   
Anyone able to reproduce this? We might have fixed this in the meantime so I'd be very interested to hear if you've seen this problem earlier but not lately. - ar
(0000495)
smdesai   
10-20-04 19:34   
I still get traceback messages. I've uploaded the SqueakDebug and a snapshot of the error. The connection was attempted between two PCs running on the same subnet with the latest updates.
(0001546)
dgd   
05-30-05 13:40   
In my linux box I get exactly the same error. The problem is that 'NetNameResolver localHostAddress' answers 127.0.0.1 in some configurations.

The actual asumption, in NetNameResolver and SocketPlugin, of gaving one and only one ip address per machine is wrong.

I didn't find the way to look for all the ip address for a machine, so a simply hack is goind to save us: Just ask the user for the IP in these bugy cases.
(0001547)
dgd   
05-30-05 13:42   
I just attached one simply changeset containing the hack.