SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

Mantis - Squeak
Viewing Issue Advanced Details
4654 ToolBuilder minor always 08-28-06 06:01 09-09-08 15:15
closed 3.9  
none 3.10  
0004654: In 7054 the workspace bug reported in Mantis #2993 has reappeared.
See 0002993 for the recipe and description.
The fixed method has been reverted to an earlier version.

'md 2/25/2006 19:01 MorphicUIManager edit:label:accept: {ui requests}'

has reverted to:

'ar 7/17/2005 00:27 MorphicUIManager edit:label:accept: {ui requests}'

Reloading the fix cured the symptom.

related to 0006429closed  [Fix ] Test suite could not run tests because they didn't follow naming convention. 
related to 0002993closed MarcusDenker [Bug] UIManager opening Workspace window w/o the proper model. 
related to 0005669closed  Workspace openFile: convenience method 
 MorphicUIBugTest-wiz.3.cs [^] (3,162 bytes) 01-03-07 22:56
 OpenWorkSpaceFix-wiz.3.cs [^] (1,844 bytes) 01-03-07 22:58
 OpenWorkSpaceFix2-wiz.1.cs [^] (2,329 bytes) 01-03-07 22:59

10-05-06 01:09   
Reminder sent to: stef

Hi stef,

You were calling for RC2 needed fixes.

The reversion of marcus's fix for this one leaves a showstopper in 7061 IMHO.

Cheers, -Jer
10-17-06 21:53   
Mantis 2993 got closed saying the fix would be in 7004.

Checking my old images I find that the fix did NOT get into 7004.

The bug cropped up somewhere after Squeak 6995 and Squeak 7001.
When the new UI stuff was put in.
01-03-07 23:08   
MorphicUIBugTest-wiz.3.cs are tests to demo the problem.
goes out and finds the window and checks to see if it has the workspace model.
a second test checks to see if the edit... method returns the window it opens.

OpenWorkSpaceFix-wiz.3.cs fixes things by patching just the
edit:laber:accept: method.

It hardwires Workspace where Stringholder was hardwired.
adds a line to set the windows model to holder
adds a return line to answer the window.

The OpenWorkSpaceFix2-wiz.1.cs fixes things along the same lines as Marcus's fix in 2993. I had to add answering returns to a bunch of stringholder methods inorder to get the answer test to work.

Most of my time was spent writing the tests. It helped alot in proving the second attempt.

Add the tests. Choose one of the fixes to taste.

Yours in service, --Jerome Peace
04-16-07 18:47   
Hi Edgar,

The fix for this bug did not get into 7088 despite your attempts.

'From Squeak3.10alpha of 30 March 2007 [latest update: 0007088] on 16 April 2007 at 2:53:06 am'
"Change Set: 7086OpenWorkSpaceFix.1.cs Date: 16 April 2007

MorphicUIBugTest run: #openWorkspaceTest

still fails.
There is no code associated with this fix.
And I mean the code in the MCn changeset that follows this changeset was empty. Which it should not have been. The fix is not sticking and the diff file does return code."
It did not get in?"

Hi Edgar,

This is very strange.
I have now seen 3 attempts to get this fix in that have failed to change anything.

So why not try to use:


as the fix on the next attempt?

The test to run is

MorphicUIBugTest run: #openWorkspaceTest

and I suggest doing it manually. Either selecting it in a workspace or from the comment within #openWorkspaceTest. For some reason from the Test runner tool when I select just this test I could not get it to actually run.

Also I am curious as to why there is a persistent problem in getting this fix to stick.

Yours in puzzlement and service, --Jerome Peace
04-16-07 18:48   
Reminder sent to: edgardec

Hi Edgar,

See my latest note.

Cheers, -Jer

P.S. Keep up the good work.
04-18-07 01:41   

>The test to run is

>MorphicUIBugTest run: #openWorkspaceTest

>from the comment within #openWorkspaceTest.
>For some reason from the Test runner tool when I select just this test I >could not get it to actually run.

found out why. The test runner chooses which methods to run based on the prefix 'test. I didn't know thiat an misnamed most all my tests by using Test as a postfix. opps. back to the drawing board.
04-18-07 20:41   

The reason the tests did not run in the suite was the way it was named.
See: 0006429 for fix for test names.

as of 7091 the Workspace bug is still present in the image.
04-19-07 03:53   
HI Edgar,

From your private email it looks like you solved it.

I will mark this resolved until I get a chance to test the next image you generate.

Thanks for a heroic job, -Jer

04-19-07 03:56   
Cross our fingers
11-24-07 16:54   
Has this issue been fixed? I can't tell from the comments
11-24-07 19:42   
But you could see both related report are in image for a while.
Or you find some new ?
For me is solved
11-24-07 19:53   
I see no comment that this has been incorperated into 3.10. but in 0006429, you say this is change 7116. So, is this issue fixed in 7116setHeadingFix-wiz-1.1.cs?
11-24-07 20:12   
Hi Matthew,

You can open a filelist
select a file
get a menu and
request "put in a workspace"

Get the workspace menu and you will see a selection
"store on file..."
This indicates that a workspace model has been installed and we are no longer dealing with the stringholder.

Which is why I marked this resolved.

Cheers, -wiz
11-24-07 20:37   
I don't see any of those menus in my 7137. In file-list, I see "workspace with contents", not "put in a workspace". In workspace, I see "save contents to file...", not "store on file".
My image is squeak-web 7137
11-24-07 21:02   
Matthew: the workspace bug and the setHeadingFix was two different updates.
None of this two bugs is on Squeak3.10.1beta.7155.image.
What could confuse you is the test, which as Jerome said is fixed also and in the moment help to finish the two problems.
Or I was wrong ?
11-24-07 21:15   
Hi Matthew,

You are correct in the details. I wrote that "off the top of my head" without checking the actual menu. And you are quick. So I didn't get a chance to correct it myself.

The jist is correct. The workspace model is now installed when the menu item is invoked.

Generally I don't mark things resolved until they are fixed in the image.
I don't close reports immediately even then because feedback tends to happen once people see the fix in the image.

[OT] but meta.
It would be good to work out a proper protocol for handling status on mantis reports. Then publish and "require" updaters to read. You and I have been inventing rules as we go. At some point we should sync up those rules. A wiki page might be the right place to start with a mantis issue pointing to it.

11-24-07 21:50   
the reason I was confused about these several issues is that they seemed to be resolved, but I saw no note from edgar saying which change or version this was put in
09-08-08 19:27   
So can I get some sort of show off hands regarding the status of this issue? The tests in MorphicUIBugTest-wiz.3.cs were harvested in update 7080 and OpenWorkSpaceFix-wiz.3.cs was harvested in update 7086, both released with 3.10. But OpenWorkSpaceFix2-wiz.1.cs has not been harvested as of today. The discussion indicates to me that there is a judgement call on the two different solutions. Can we consider this resolved/closed yet or not?
09-08-08 21:22   
Hi Ken,

Thanks for being carefull.

As far as I can see the underlying problem is fixed in 3.10.2

Getting a filelist to put a text file in a workspace now gives you a genuine workspace and not a string holder. The noticable difference is that the workspace model adds to the menu several options including the choice to save the file to disk.

I believe the test for this is in the image as well and it runs green.

So this is resolved and can be closed imo.

Yours in service and curiosity, --Jerome Peace
09-09-08 15:15   
Thanks Jerome. This was harvested in update 7081 and released with 3.10.