Mantis - Squeak
Viewing Issue Advanced Details
7385 System major always 08-18-09 14:39 08-18-09 14:39
gsa  
 
normal  
new 3.10.2  
open  
none    
none  
0007385: Socket(Object)>>primitiveFailed
I'm trying to start an image in the form "completepath/vmname
completpath/imagename completpath/startupscript arg1" were arg1 is a port number to start WAKom.

As not worked headless I tried showing the main Squeak window and I
get the subject error with not much more info.

I'm using "Squeak 4.1.1beta2U.app" with a 3.10.2 image running on Mac
OS X Server 10.5.5.

I also tried on a linux box with a unix vm (Squeak-3.10-6.i686-pc-linux-gnu.tar.gz) and got the same error at socket level (Socket>>listenOn: /
TcpListener>>pvtOldListenLoop:).

Trying a bit more on Linux and debugging, the error show:

Socket(Object)>>doesNotUnderstand: #waitForConnectionUntil:

On the debugger, on TcpListener I can see that port is ok, and the
handler is "seaside [running] port: 8888", the port that I passed,
but.....the image don't respond on such port and the debugger get fired.


My script only read the port, as follow:

| port |
port := SmalltalkImage current getSystemAttribute: 3.
WAKom stop.
WAKom startOn: port.

The script will be more complex in the future, now is at this way only
to try if works.

There are no notes attached to this issue.