Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001071 [tweak] Obscure Bugs tweak always 04-13-05 15:24 04-22-05 07:25
Reporter corny View Status public  
Assigned To
Priority normal Resolution fixed  
Status resolved  
Summary 0001071: CDropDownList doesn't add new items
Description Documentation in CDropDownList said: "... If the list is editable, then the user can type into the input field. Upon accepting the input, the list will add in the new accepted value."

- click Widgets->Lists->DropDownList
- set the List to... allowEditing: true
- click on the list arrow and pick an item from the list.
- click in the list's textfield (marking the current item) and type in your own text, accept by hitting ENTER

I expect: the list's textfield will show my recently entered text
I expect: the new Item I just typed in, will from now on be available in the dropdown list

what happened: the list's textfield shows blank
what happened: the new item i just typed in, is NOT available as a new item in the list
Additional Information
Attached Files

- Relationships

- Notes
(0001402 - 244 - 256 - 400 - 400 - 400 - 400)
andreas
04-22-05 07:24

The first issue (item not showing up when accepting) is fixed. The second (item not in list) is not a bug in the code but in the documentation - the class comment has been fixed, too. See also:

http://tweak.impara.de/ABOUT/FAQ#WidgetBehavior [^]
 

- Issue History
Date Modified Username Field Change
04-13-05 15:24 corny New Issue
04-22-05 07:24 andreas Status new => resolved
04-22-05 07:24 andreas Resolution open => fixed
04-22-05 07:24 andreas Assigned To  => andreas
04-22-05 07:24 andreas Note Added: 0001402
04-22-05 07:25 andreas Assigned To andreas =>


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
36 total queries executed.
30 unique queries executed.
Powered by Mantis Bugtracker