Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001103 [tweak] Any minor always 04-22-05 19:40 04-22-05 22:02
Reporter bert View Status public  
Assigned To
Priority normal Resolution open  
Status feedback  
Summary 0001103: bewareOf:
Description The native speakers' majority said the term "beware of" would be wrong, it should have actually been "be aware of". My suggestion would be to replace it with "changeEvent:" because that is most descriptive, and reduces the number of terms we have to explain and remember.

An even better alternative might be to remove the annotation altogether. Its meaning is one of the most asked questions - people tend to think it actually signals some event. So once we have a better UI or syntax for field descriptions just change it there.
Additional Information
Attached Files

- Relationships

- Notes
(0001421 - 542 - 558 - 558 - 558 - 558 - 558)
andreas
04-22-05 22:02

Well, maybe we should change the name away from bewareOf: - but I have not seen any conclusion on what the "right" name would be. About removing it completely: So then, how do you find out, which event is signaled for, say, CPlayer>>angle? The point about them is that they serve as documentation at least as much as anything else. Using them formally (e.g., by field refs etc) simply makes sure we keep track of them since if *that* documentation breaks so does your code. If people ask about those annotations it is a Good Thing in my book.
 

- Issue History
Date Modified Username Field Change
04-22-05 19:40 bert New Issue
04-22-05 22:02 andreas Note Added: 0001421
04-22-05 22:02 andreas Status new => feedback


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
33 total queries executed.
28 unique queries executed.
Powered by Mantis Bugtracker