Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000200 [Squeak] Any feature always 09-30-04 20:43 07-29-05 21:22
Reporter ducasse View Status public  
Assigned To
Priority normal Resolution open  
Status closed   Product Version
Summary 0000200: refresh problem in 3.8unstable 6273
Description I'm using 3.8 unstable and I found that the refresh of the window was slower and also invalidating far too much
and redrawing the complete far too much especially when a debugger pops up. I'm using the latest VM of john on mac.
Am I the only one?

No, I noticed this too. It made the image pretty much unusable.
Additional Information
Attached Files  FixDebuggerOpening.1.cs [^] (2,089 bytes) 07-20-05 13:13

- Relationships
related to 0001348closed  drawing on os-x becomes very slow. 

- Notes
(0000285 - 613 - 773 - 901 - 901 - 901 - 901)
MarcusDenker
10-10-04 15:12

Subject: [BUG] refresh display (only on mac I guess)
Author: Stephane Ducasse
Date Posted: 11 May 2003
Archive ID: 9860
Comments: Hi all

I think that this bug is only occurring on mac. Nathanael was tracking
it but could not reproduce it.
I have the impression that this is the same I found and I'm able to
reproduce it.

load from
http://minnow.cc.gatech.edu/squeak/3083 [^]
    - KCP-0063
    - KCP-0067

then do Smalltalk beep, the method beep is deprecated to a debugger
pops up warning us, press proceed
then the sound is played but the UI is redrawn in a ugly and slow
manner piece by piece.
 
(0001848 - 157 - 163 - 163 - 163 - 163 - 163)
MarcusDenker
07-20-05 13:14

The attached seems to fix it for me... this uses some hints that Andreas sent to the list, but
I am no expert with morphic, so it could be completely wrong.
 
(0002037 - 31 - 31 - 31 - 31 - 31 - 31)
MarcusDenker
07-29-05 21:21

I think this is fixed... I hope
 

- Issue History
Date Modified Username Field Change
09-30-04 20:43 ducasse New Issue
10-10-04 15:12 MarcusDenker Note Added: 0000285
07-20-05 13:13 MarcusDenker File Added: FixDebuggerOpening.1.cs
07-20-05 13:14 MarcusDenker Note Added: 0001848
07-28-05 11:24 MarcusDenker Relationship added related to 0001348
07-29-05 21:21 MarcusDenker Status new => closed
07-29-05 21:21 MarcusDenker Note Added: 0002037


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
48 total queries executed.
34 unique queries executed.
Powered by Mantis Bugtracker