Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000336 [Croquet] Jasmine text always 10-12-04 10:36 10-20-04 09:44
Reporter Darius Clarke View Status public  
Assigned To andreas
Priority normal Resolution won't fix  
Status resolved  
Summary 0000336: SqueakDebug.log overwrites the file rather than appends each entry
Description Make sure to let all the new developers know about the SqueakDebug.log when reporting errors.

Mention it in all the readme & other developer docs.
Additional Information
Attached Files

- Relationships

- Notes
(0000394 - 122 - 122 - 122 - 122 - 122 - 122)
bert
10-16-04 03:03

This is actually intentional, we are usually only interested in the latest walkback. Any compelling reason to change this?
 
(0000396 - 201 - 201 - 201 - 201 - 201 - 201)
Darius Clarke
10-16-04 03:22

Because I hit proceed to try to explore further and lose the original error in a wave of side effects unless I take the time to recreate. Sometimes multipule walkbacks occur after only one user action.
 
(0000398 - 201 - 201 - 201 - 201 - 201 - 201)
Darius Clarke
10-16-04 03:24

Because I hit proceed to try to explore further and lose the original error in a wave of side effects unless I take the time to recreate. Sometimes multipule walkbacks occur after only one user action.
 
(0000459 - 387 - 397 - 397 - 397 - 397 - 397)
andreas
10-19-04 02:46

Darius - while I agree that there can be occasional annoyances with this behavior most of the time it is rather useful and prevents filling up your disk with random errors (you'd be surprised how many errors occur during a random hacking session) and it is relatively simple to make a copy of the SqueakDebug.log if you need it. Thusly, I think the bug should be resolved as "won't fix".
 
(0000463 - 135 - 145 - 145 - 145 - 145 - 145)
Darius Clarke
10-19-04 02:54

Limiting it to the "last 5 errors" might add a significant more context without causeing the problems you raise in your valid concerns.
 
(0000477 - 1048 - 1082 - 1082 - 1082 - 1082 - 1082)
andreas
10-19-04 10:21

This sounds good in theory but is impossible to do in practice. We simply don't know what gets written into the debug log and trying to find out would require us to parse the entire file, figure out where exactly the last five bugs are and then rewrite the whole thing.

Even if it were possible I would argue against it - error logging is a facility which you rely mostly on when things get ugly and complications in error logging code only lead to the effect that you won't get a log just when you need it most. Utter simplicity is a must.

I'm still in favour of "won't fix". The only alternative would be to add a preference which controls whether we append logs to SqueakDebug.log or overwrite it. But, really, I cannot possibly see how you would use a SqueakDebug.log which -after a few weeks of use- easily contains dozens of errors. I'm getting already confused by this with the VM's crash log (which appends instead of overwrites because these crashes are typically hard to reproduce) and crashes happen perhaps once every two months.
 
(0000478 - 91 - 101 - 101 - 101 - 101 - 101)
bert
10-19-04 11:00

It's not even "won't fix", it's not a bug at all IMHO. It's *definitely* not a Croquet bug.
 
(0000488 - 100 - 100 - 100 - 100 - 100 - 100)
Darius Clarke
10-20-04 08:54

I'll conced the point. If one really needs it. They can add it themselves. Please close this report.
 
(0000490 - 24 - 24 - 24 - 24 - 24 - 24)
andreas
10-20-04 09:44

See bug note discussion.
 

- Issue History
Date Modified Username Field Change
10-12-04 10:36 Darius Clarke New Issue
10-16-04 03:03 bert Note Added: 0000394
10-16-04 03:03 bert Status new => feedback
10-16-04 03:22 Darius Clarke Note Added: 0000396
10-16-04 03:24 Darius Clarke Note Added: 0000398
10-19-04 02:46 andreas Note Added: 0000459
10-19-04 02:54 Darius Clarke Note Added: 0000463
10-19-04 10:21 andreas Note Added: 0000477
10-19-04 11:00 bert Note Added: 0000478
10-20-04 08:54 Darius Clarke Note Added: 0000488
10-20-04 09:44 andreas Status feedback => resolved
10-20-04 09:44 andreas Resolution open => won't fix
10-20-04 09:44 andreas Assigned To  => andreas
10-20-04 09:44 andreas Note Added: 0000490


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
69 total queries executed.
47 unique queries executed.
Powered by Mantis Bugtracker