Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000362 [Croquet] Jasmine major always 10-13-04 07:17 10-19-04 09:40
Reporter mshirley View Status public  
Assigned To andreas
Priority normal Resolution fixed  
Status resolved  
Summary 0000362: OpenGL window remains topmost when switching projects
Description In a clean Croquet0.1image
Switch to First Steps
Update code from server
Start teapot
Jump to project "fun with music" (left click on background,
  select "jump to project)

BUG: OpenGL window is still visible, although it's not
getting updated normally.

Left click, menu, previous project

Back to normal.

Possible bug (I'm staring at this bug, but I haven't seen it
consistently; I think this bug has been reported elsewhere
too): the Z order of the windows in the First Steps
workspace is wrong. In the case I'm looking at, the
workspace came out on top, unexpectedly. When I click on
the workspace to move it, the 'drag rectangle' appears to be
under the OpenGL window. At this stage, I don't see how to
the OpenGL window back on top. (Jumping to another
workspace and back didn't fix the order.)
Additional Information
Attached Files

- Relationships

- Notes
(0000440 - 105 - 105 - 105 - 105 - 105 - 105)
andreas
10-18-04 08:16

Ah, yes. The good ol' intoWorld: bug. I thought that had been fixed by 3.6 but apparently not. Ho hum....
 
(0000472 - 185 - 185 - 185 - 185 - 185 - 185)
andreas
10-19-04 09:40

Added a crude workaround since fixing this problem in its entirety would require a major adoption of code from 3.7 (and it isn't really worth it for the singular problem we are facing).
 

- Issue History
Date Modified Username Field Change
10-13-04 07:17 mshirley New Issue
10-18-04 08:16 andreas Note Added: 0000440
10-18-04 08:16 andreas Status new => acknowledged
10-19-04 09:40 andreas Status acknowledged => resolved
10-19-04 09:40 andreas Resolution open => fixed
10-19-04 09:40 andreas Assigned To  => andreas
10-19-04 09:40 andreas Note Added: 0000472


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
40 total queries executed.
32 unique queries executed.
Powered by Mantis Bugtracker