Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000364 [Croquet] Jasmine feature always 10-13-04 07:39 10-21-04 11:17
Reporter mshirley View Status public  
Assigned To andreas
Priority normal Resolution suspended  
Status resolved  
Summary 0000364: Add 'submit bug report' action to the debugger or error pane
Description A feature that the MIT and later symbolics lisp machines
had was a 'submit bug report' feature built into the
debugger. Selecting that option preloaded a mail message
with information about the state (hardware, os,
stack trace) and then left room for the user's comments.

In your case, you could do the equivalent using SMTP or, much better
since you want bug reports to come into Mantis, you could
create a workspace filled with text describing the state
that could be cut and pasted into a mantis bug report.

Many bugs don't drop the user into the debugger, but
training your users to do this for those that do, can help
you get full reports.
Additional Information
Attached Files

- Relationships

- Notes
(0000335 - 369 - 399 - 399 - 399 - 399 - 399)
mshirley
10-13-04 08:00

Arrgh. I'm still learning. I see a 'mail out bug report'
option in the debugger. That assumes you want to mail it out,
but you're encouraging us to use Mantis. I still think
(a) making it painfully obvious for your many new users and (b)
writing the information to a workspace so it can be pasted into
your website (rather than emailed) is what you want to do.
 
(0000351 - 217 - 217 - 217 - 217 - 217 - 217)
johnmci
10-13-04 19:50

Thought, what if the email contained sufficent information such that an automatic process could build a Mantias bug report. Keeping the error reporting path simple or automatic wil result in better capturing of issues
 
(0000356 - 1108 - 1222 - 1222 - 1222 - 1222 - 1222)
mshirley
10-13-04 20:54

Keeping the error reporting path simple will certainly result in better
capturing of issues. That's probably the ideal solution, but it would
involve work on a support program, likely not in smalltalk, taking
effort away from Croquet itself.

Since submitting this, I've found the operation for dumping a debug log,
SqueakDebug.log. That's almost the right thing. My suggestion has
reduced to pointing out that the currently implemented feature is
obscure for new users and inconvenient to use.

One solution is to simply document the procedure for submitting a bug
report in some prominant place. That is, make it less obscure.

A more fun solution might be to submit the bug directly from Croquet to
Mantis using HTTP, so it would be as simple as mailing the bug report
used to be. But that's more work than just documenting what to do.
And, if Croquet gets slashdotted and lots of people are playing with it,
the implementors might like to have a small barrier to bug reporting.
I think documenting how to submit a report on the Croquet website is the
simplest, near-term solution.
 
(0000504 - 184 - 184 - 184 - 184 - 184 - 184)
andreas
10-21-04 11:17

This should be addressed in the context of Squeak not Croquet. Both use the bug tracker here at impara.de and if there's anyone interested in fixing this please do so for both systems.
 

- Issue History
Date Modified Username Field Change
10-13-04 07:39 mshirley New Issue
10-13-04 08:00 mshirley Note Added: 0000335
10-13-04 19:50 johnmci Note Added: 0000351
10-13-04 20:54 mshirley Note Added: 0000356
10-21-04 11:17 andreas Status new => resolved
10-21-04 11:17 andreas Resolution open => suspended
10-21-04 11:17 andreas Assigned To  => andreas
10-21-04 11:17 andreas Note Added: 0000504


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
48 total queries executed.
37 unique queries executed.
Powered by Mantis Bugtracker