Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000370 [Croquet] Any trivial always 10-13-04 18:43 10-13-04 23:25
Reporter dgd View Status public  
Assigned To Croqueteer
Priority normal Resolution fixed  
Status resolved  
Summary 0000370: [ENH] Full Screen for TeaMorph
Description New full-screen option in TeaMorph's menu
Additional Information
Attached Files  TeapotMorphFullScreen-dgd.1.cs.gz [^] (530 bytes) 10-13-04 18:43
 TeapotMorphFullScreen-v2-dgd.1.cs.gz [^] (665 bytes) 10-13-04 19:41
 TeapotMorphFullScreen-v3-dgd.3.cs.gz [^] (888 bytes) 10-13-04 23:08

- Relationships

- Notes
(0000349 - 216 - 216 - 216 - 216 - 216 - 216)
Croqueteer
10-13-04 19:11

Can we have a corresponding menu item when we jump to full screen to also reduce to our original size? I will post it then. I like to move back and forth a lot between the two when debugging, so this would be useful.
 
(0000350 - 14 - 14 - 14 - 14 - 14 - 14)
dgd
10-13-04 19:41

See version 2.
 
(0000357 - 338 - 338 - 338 - 338 - 338 - 338)
Croqueteer
10-13-04 21:13

This jumps the teapot morph into the top left corner first time, second time goes full screen and third jumps it back into the top left corner. Is there any way to have it jump from whereever it is to fullscreen and then back? (You could compare bounds to the world and if not equal save these and set fullscreen - or whatever works...:-)
 
(0000359 - 573 - 805 - 805 - 805 - 805 - 805)
dgd
10-13-04 21:20

Your description sounds like the bug in unix vm.

If you save an image in FullScreen (and quit) when you open this image again the VM don't switch to full-screen mode.

Can you evaluate "ScreenController lastScreenModeSelected" as soon as you enter to Squeak and send me the result?

BTW, I created a workaround for small-land image evaluating something like:

    (('*linux*' match: Smalltalk osVersion)
            and: [ScreenController lastScreenModeSelected])
        ifTrue: [ScreenController new fullScreenOn].

in a startup.

Are you interested also in this workaround?
 
(0000360 - 114 - 114 - 114 - 114 - 114 - 114)
Croqueteer
10-13-04 21:30

Looks like the same problem on the Mac, which is what I am currently using. I guess it also needs this workaround.
 
(0000361 - 180 - 202 - 202 - 202 - 202 - 202)
dgd
10-13-04 21:34

Please send me the result of the evaluation of "Smalltalk osVersion" in Mac (I have not any apple at hand).

After this I'll upload a new changeset including also the workaround.
 
(0000362 - 81 - 105 - 105 - 105 - 105 - 105)
Croqueteer
10-13-04 21:41

All it returns is:

Smalltalk osVersion '1035'

not particularly informative.
 
(0000364 - 39 - 39 - 39 - 39 - 39 - 39)
andreas
10-13-04 21:45

Smalltalk osVersion '1035' means 10.3.5
 
(0000366 - 119 - 139 - 139 - 139 - 139 - 139)
dgd
10-13-04 22:06

What about "Smalltalk platformName" or "Smalltalk platformSubtype"? I need a way to know if Squeak is running in Apple.
 
(0000367 - 47 - 47 - 47 - 47 - 47 - 47)
dgd
10-13-04 23:08

Please try v3 on apple, it works fine on linux.
 
(0000368 - 37 - 37 - 37 - 37 - 37 - 37)
Croqueteer
10-13-04 23:25

This works on Mac as well - nice job.
 

- Issue History
Date Modified Username Field Change
10-13-04 18:43 dgd New Issue
10-13-04 18:43 dgd File Added: TeapotMorphFullScreen-dgd.1.cs.gz
10-13-04 19:11 Croqueteer Note Added: 0000349
10-13-04 19:41 dgd File Added: TeapotMorphFullScreen-v2-dgd.1.cs.gz
10-13-04 19:41 dgd Note Added: 0000350
10-13-04 21:13 Croqueteer Note Added: 0000357
10-13-04 21:20 dgd Note Added: 0000359
10-13-04 21:30 Croqueteer Note Added: 0000360
10-13-04 21:34 dgd Note Added: 0000361
10-13-04 21:41 Croqueteer Note Added: 0000362
10-13-04 21:45 andreas Note Added: 0000364
10-13-04 22:06 dgd Note Added: 0000366
10-13-04 23:08 dgd File Added: TeapotMorphFullScreen-v3-dgd.3.cs.gz
10-13-04 23:08 dgd Note Added: 0000367
10-13-04 23:25 Croqueteer Status new => resolved
10-13-04 23:25 Croqueteer Resolution open => fixed
10-13-04 23:25 Croqueteer Assigned To  => Croqueteer
10-13-04 23:25 Croqueteer Note Added: 0000368


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
82 total queries executed.
51 unique queries executed.
Powered by Mantis Bugtracker