Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000376 [Croquet] Jasmine major always 10-14-04 03:00 04-25-05 00:04
Reporter davidkkim View Status public  
Assigned To andreas
Priority normal Resolution fixed  
Status resolved  
Summary 0000376: Error: Callout mechanism not available using ATI Radeon 9800Pro, glEnable
Description When starting Jasmine and dragging a Teapot onto the main window (in the First Steps project), I get a pale blue rectangle and, a few seconds later, the above error.

The call stack shows that the error seems to originate
from the TeapotMorph>>drawAcceleratedOn: method,
specifically when it sends:
ogl glEnable: GLTexture2d.

I am using an ATI Radeon 9800 Pro card.
Worrying about the OpenGL drivers, I uninstalled my current drivers and installed the latest downloaded Catalyst drivers from ATI. This did not help.

Testing on another computer, using an NVideo GeForce Ti4200 resulted in a functioning environment (3d landscape, Alice, etc.)

I used the OpenGL extensions viewer to check my configuration. It did show the following report
"No 8bit palette texture support.
This may leads performance loss on some old applications."

I am wondering if this is the problem (I do not have OpenGL experience specifically). I could not find alternate drivers.

When I force my display to 8-bits, some images show up, but they do not appear normal (pixelated and incomplete, as if they were 2 bits deep).

Any advice appreciated. The Radeon 9800s are still reasonably current cards, with a wide user base. So I am probably not the only one who would be interested in a fix or workaround.
Additional Information
Attached Files

- Relationships

- Notes
(0000379 - 771 - 795 - 795 - 795 - 795 - 795)
andreas
10-14-04 04:02

David - this bug is unrelated to the OpenGL drivers. The error message indicates that we cannot find the FFI (foreign function interface) to actually execute the OpenGL calls (and then of course everything fails). You should check if there is a SqueakFFIPrims.dll right next to Squeak.exe (on Windows; the names are slightly different on Mac/Unix). It may also be the case that (if you had a Squeak installation before) you are accidentally using another version of the VM which does not have the FFI plugin around.

A good thing to try would be to move the dll from the bin directory into the Croquet root directory (e.g., next to Croquet0.1.image). This may just work (the VM looks in the image directory too if it searches for plugins).

Let us know if that works.
 
(0000380 - 636 - 702 - 868 - 868 - 868 - 868)
davidkkim
10-14-04 06:23

Dear Andreas - Thank you for your exceptionally quick response!
I tried what you had suggested, as well as changing my system PATH variable. Neither worked. On a hunch, I did copy another version of the file I found (using a Google search) from the following location:

http://isgwww.cs.uni-magdeburg.de/~raab/squeak/bin/latest/ [^]
The SqueakFFIPrims.dll file was dated 5/17/00, measuring 28k.

So I am not sure if the file included in the distribution was newer
or older, but this one works. It now rapidly loads the 3D environment,
which is a wonder to behold. I look forward to exploring it!

Best regards,
David
 
(0000381 - 335 - 335 - 335 - 335 - 335 - 335)
andreas
10-14-04 10:11

I'm declaring this bug fixed for now. I'm still uncertain what the root cause for the problem is but I'm virtually certain that it's specific to David - if it weren't we'd hear lots and lots of similar bug reports. And that's one of the reasons why I'm resolving this - if there are any others having the same problem I want to see it.
 
(0001428 - 137 - 137 - 137 - 137 - 137 - 137)
Croqueteer
04-25-05 00:04

I found that we have this problem with the 3.7 version of the SqueakFFIPrims.dll. I replaced the VM and the dll and was able to continue.
 

- Issue History
Date Modified Username Field Change
10-14-04 03:00 davidkkim New Issue
10-14-04 04:02 andreas Note Added: 0000379
10-14-04 05:51 davidkkim Issue Monitored: davidkkim
10-14-04 06:23 davidkkim Note Added: 0000380
10-14-04 10:11 andreas Status new => resolved
10-14-04 10:11 andreas Resolution open => fixed
10-14-04 10:11 andreas Assigned To  => andreas
10-14-04 10:11 andreas Note Added: 0000381
04-25-05 00:04 Croqueteer Note Added: 0001428
08-19-05 10:34 jsk Issue Monitored: jsk


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
53 total queries executed.
38 unique queries executed.
Powered by Mantis Bugtracker