Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000408 [Croquet] Any crash always 10-16-04 22:35 10-26-04 21:11
Reporter kat View Status public  
Assigned To
Priority normal Resolution no change required  
Status resolved  
Summary 0000408: Teapot crashes Squeak before fully initialising.
Description When I drag Teapot [or Sample Teapot, TeaTest, or Tweak Teapot], a blue opengl window appears, and then disappears. Squeak crashes.
Additional Information I'm using Linux 2.6.8, with xorg 6.8. I have a Radeon 9200. I don't use the ATI drivers (I use the xorg 'radeon' driver). OpenGL appears to work with Squeak; I can get a blue window which I can drag around, and Squeak doesn't crash.

The error given on the console is: X Error of failed request: BadMatch (invalid parameter attributes)
  Major opcode of failed request: 1 (X_CreateWindow)
  Serial number of failed request: 1317
  Current serial number in output stream: 1319
The last two numbers vary.

Running /bin/bash Croquet.sh under gdb gives me this:
Program received signal SIGFPE, Arithmetic exception.
An attempt at getting a backtrace didn't provide much info; the last line was:
0000083 0x0807d117 in extract_arithmetic_subst (string=0x407a624c "Testing OS support for SSE unmasked exceptions... ", sindex=0x4074b382) at subst.c:862
Previous frame inner to this frame (corrupt stack?)
Attached Files  Squeak3D.log [^] (2,123 bytes) 10-16-04 23:22

- Relationships

- Notes
(0000417 - 214 - 224 - 224 - 224 - 224 - 224)
bert
10-16-04 23:08

Sounds like a driver bug to me. How do you know OpenGL works? The light blue window is not yet using OpenGL. Please try "TGraphicsTest new open", and attach the Squeak3d.log file. Also, you might try other drivers.
 
(0000418 - 446 - 446 - 446 - 446 - 446 - 446)
kat
10-16-04 23:32

The test also crashes Squeak; I didn't realise that the blue window wasn't actually using OpenGL, sorry. OpenGL in general works on my computer; for instance, I can use glxgears and tuxracer [neither crash.] For what it's worth, I already had a squeak installation [also 3.6] before downloading Jasmine; as I didn't edit the .sh file, I don't think that should matter, though, as that refers explicitely to the new one; correct me if I'm wrong.
 
(0000421 - 209 - 209 - 209 - 209 - 209 - 209)
bert
10-17-04 00:10

Yes, the .sh file should use the new squeak VM. Did the shell script create a link to libGL.so? If not, what does /usr/lib/libGL.so point to? Same lib as the one B3DAccceleratorPlugin.so is bound to (use ldd)?
 
(0000425 - 581 - 717 - 717 - 717 - 717 - 717)
kat
10-17-04 01:43

No, no link was created.

% ls -lh /usr/lib/libGL.so
lrwxrwxrwx 1 root root 41 Oct 14 16:52 /usr/lib/libGL.so -> /usr/lib/opengl/xorg-x11/lib/libGL.so.1.2*

% md5sum /usr/lib/opengl/xorg-x11/lib/libGL.so.1.2
0b5d98132dfc5fc3801b72b546abebfc /usr/lib/opengl/xorg-x11/lib/libGL.so.1.2


% ldd bin/i686-pc-linux-gnu/B3DAcceleratorPlugin.so | grep GL
        libGL.so.1 => /usr/X11R6/lib/libGL.so.1 (0x4000e000)

% md5sum /usr/X11R6/lib/libGL.so.1
0b5d98132dfc5fc3801b72b546abebfc /usr/X11R6/lib/libGL.so.1

Different file-names, but the contents seem to be the same.
 
(0000527 - 229 - 245 - 245 - 245 - 245 - 245)
kat
10-26-04 19:15

I've managed to track this down to an X11 extension.
In the "Extensions" section [new in xorg 6.8], if Composite is enabled, the crashes occur; if it's not, they don't. Nothing other than opengl under squeak has been crashing.
 
(0000528 - 457 - 525 - 525 - 525 - 525 - 525)
bert
10-26-04 21:11

Ah, that explains it. I contacted Keith Packard (X.org guru) and he had to say this:

"The new Composite extension is disabled by default because it can cause
problems like this when interacting with a direct rendering GL library.

I'm hoping we'll see these bugs get fixed soon. Until then, if you want
to run GL, you'll need to disable the Composite extension."

So. I resolve this as "not a bug" for now, as it is apparently not a Croquet bug.
 

- Issue History
Date Modified Username Field Change
10-16-04 22:35 kat New Issue
10-16-04 23:08 bert Note Added: 0000417
10-16-04 23:08 bert Status new => feedback
10-16-04 23:08 bert Additional Information Updated
10-16-04 23:22 kat File Added: Squeak3D.log
10-16-04 23:32 kat Note Added: 0000418
10-17-04 00:10 bert Note Added: 0000421
10-17-04 01:43 kat Note Added: 0000425
10-26-04 19:15 kat Note Added: 0000527
10-26-04 21:11 bert Note Added: 0000528
10-26-04 21:11 bert Status feedback => resolved
10-26-04 21:11 bert Resolution open => no change required


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
60 total queries executed.
40 unique queries executed.
Powered by Mantis Bugtracker