Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000412 [Croquet] Jasmine major always 10-18-04 02:57 10-21-04 06:52
Reporter Croqueteer View Status public  
Assigned To Croqueteer
Priority urgent Resolution fixed  
Status resolved  
Summary 0000412: Jasmine is half speed of Solar
Description For some reason that I have not been able to determine yet, Solar is almost twice as fast as Jasmine on complex scenes. It is faster on everything actually, but the aqueduct world is quite noticeable. At the moment, I don't know what it could be. I thought it might be textures, and though these seem to be something of a problem, even when I turned off textures entirely by turning off enable/disable, there still wasn't a really significant improvement in speed.

So the bad news is we have some kind of rendering problem.

The good news is once we fix it, Croquet will run almost twice as fast.
Additional Information
Attached Files

- Relationships

- Notes
(0000482 - 433 - 438 - 438 - 438 - 438 - 438)
Croqueteer
10-19-04 17:56

This problem is far more pronounced on the Mac than on Windows. The two machines I have - a Mac PowerBook 17" and a Panasonic R3, are about equivalent on Solar, but the Mac is almost exactly 1/2 the speed of the R3 in Jasmine. In the full entry world (TeapotMorph) the R3 gets 30 FPS, while the Mac gets about 13-15. As a side note, I noticed a huge number of semaphore processes, which seem to be leftovers from inappropriate exits.
 
(0000501 - 355 - 355 - 355 - 355 - 355 - 355)
Croqueteer
10-21-04 06:52

This was a problem with the TQuadTree adding the frame contents twice. This was due to a side effect of the #reinstall occurring before the initial install. That is, it was already installed by the time it started the first install. I think this was caused by a slight change in order of execution. I decided to just rewrite this problem out of existence.
 

- Issue History
Date Modified Username Field Change
10-18-04 02:57 Croqueteer New Issue
10-18-04 02:58 Croqueteer Priority normal => urgent
10-18-04 02:58 Croqueteer Severity feature => major
10-19-04 17:56 Croqueteer Note Added: 0000482
10-21-04 06:52 Croqueteer Status new => resolved
10-21-04 06:52 Croqueteer Resolution open => fixed
10-21-04 06:52 Croqueteer Assigned To  => Croqueteer
10-21-04 06:52 Croqueteer Note Added: 0000501


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
40 total queries executed.
33 unique queries executed.
Powered by Mantis Bugtracker