Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000428 [Croquet] Jasmine crash always 10-20-04 23:54 10-21-04 03:52
Reporter greg rivera View Status public  
Assigned To andreas
Priority normal Resolution fixed  
Status resolved  
Summary 0000428: negative-HorResize window crashes, highBit not defined for negatives
Description a) start FirstSteps/SampleTeapot, get handles, drag 'resize' left and right. if dragged too far left, 3dscreen goes to very narrow (ok), then error "highBit not defined for negative integers"

b) also, quickly gets "***System error handling failed***" type any other char to restart
 
Tweak: for vertical resize (pulling bottom above the top), it ignores message if bottom is above top (bug). It should set window to min hite (min valid value). I.e., (currently wrong) resizing slowly will get you smallest hite, resizing quickly gets ignored. Correct behavior should be to get same results despite human/cursor (machine/refresh) speed.

Minor: min hite seems to be zero? So window effectively disappears? or so small its very very hard to select it to correct it. Is there a min win hite/width?

(hmm, probably squeak/window bug, rather than jasmine, oh well.)
Additional Information
Attached Files

- Relationships

- Notes
(0000499 - 69 - 69 - 69 - 69 - 69 - 69)
andreas
10-21-04 03:52

Actually this is a Jasmine bug (not a generic Squeak bug). Now fixed.
 

- Issue History
Date Modified Username Field Change
10-20-04 23:54 greg rivera New Issue
10-21-04 03:52 andreas Status new => resolved
10-21-04 03:52 andreas Resolution open => fixed
10-21-04 03:52 andreas Assigned To  => andreas
10-21-04 03:52 andreas Note Added: 0000499


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
35 total queries executed.
30 unique queries executed.
Powered by Mantis Bugtracker