Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004291 [Croquet] Hedgehog minor always 07-20-06 00:53 12-04-06 22:11
Reporter howardstearns View Status public  
Assigned To howardstearns
Priority normal Resolution fixed  
Status resolved  
Summary 0004291: TGroup>>colorize: fails on null frameChildren
Description Most uses of frameChildren have a frameChildren ifNil: guard. This one doesn't.
Additional Information This came up for me because I used a sometimes-deliberately-empty TGroup as the affordance for a TButton.

Trival fix attached.
Attached Files  TGroup-colorize.st.gz [^] (225 bytes) 07-20-06 00:53

- Relationships

- Notes
(0008545 - 44 - 44 - 44 - 44 - 44 - 44)
howardstearns
12-04-06 22:11

Fixed in repository (Croquet-Objects-ar.238)
 

- Issue History
Date Modified Username Field Change
07-20-06 00:53 howardstearns New Issue
07-20-06 00:53 howardstearns File Added: TGroup-colorize.st.gz
12-04-06 22:11 howardstearns Status new => resolved
12-04-06 22:11 howardstearns Resolution open => fixed
12-04-06 22:11 howardstearns Assigned To  => howardstearns
12-04-06 22:11 howardstearns Note Added: 0008545


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
36 total queries executed.
29 unique queries executed.
Powered by Mantis Bugtracker