Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000436 [Croquet] Jasmine minor always 10-21-04 19:19 01-06-05 18:34
Reporter samy View Status public  
Assigned To
Priority normal Resolution fixed  
Status resolved  
Summary 0000436: When using pointer on a reflected image on a mirror the pointer interacts with the original object
Description Maybe this could be a feature and not a bug, if you consider the pointer ray reflects on the mirror...

- Open a squeak project, or whatever object that you can interact with with the pointer.
- place the object in front of a mirror
- look at the mirror, and see how you can interact with the object while using the pointer on the mirrored image
Additional Information
Attached Files

- Relationships

- Notes
(0000506 - 349 - 369 - 369 - 369 - 369 - 369)
bert
10-21-04 19:30

The behaviour is exactly what you want, so you can manipulate the objects in the mirror. However, what's disturbing is that the *rendering* of the laser does not go "into" the mirror, but goes directly from the avatar to the object on this side of the mirror. It would look much cooler if the laser went "into" the mirror and was reflected there ...
 
(0000507 - 504 - 514 - 514 - 514 - 514 - 514)
Croqueteer
10-21-04 21:37

The "correct" behavior is for the ray to bounce in this case - or in the case of through a portal selection, you should see the ray extended through. We actually know when and where we hit portal, as that is part of the process of selection through one, so what we would need to do is generate a list of these (as we may actually select through MULTIPLE portals) and link them. I suggest we keep this open as a bug - because the current behavior is incorrect, but not be terribly concerned about for now.
 
(0000515 - 588 - 588 - 588 - 588 - 588 - 588)
jlombardi
10-22-04 15:57

I think that it would be appropriate to maintain the behavior as it currently is for the originator of the pointer - that is to say, the pointer does not reflect on the surface of the mirror. However, I believe that there might be some value in having another user see the reflection of the pointer off of the surface of the mirror. This would enable the originator of the pointer to accurately manipulate objects within mirror reflections while providing observers of such interactions a direct understanding of the origin of actions that have been directed by another user in a scene.
 
(0001006 - 130 - 130 - 130 - 130 - 130 - 130)
Croqueteer
01-06-05 18:34

This now works in a more normal manner. When you pick through a portal, including a mirror, the laser pointer stops at the portal.
 

- Issue History
Date Modified Username Field Change
10-21-04 19:19 samy New Issue
10-21-04 19:30 bert Note Added: 0000506
10-21-04 19:30 bert Status new => feedback
10-21-04 21:37 Croqueteer Note Added: 0000507
10-22-04 15:57 jlombardi Note Added: 0000515
01-06-05 18:34 Croqueteer Status feedback => resolved
01-06-05 18:34 Croqueteer Resolution open => fixed
01-06-05 18:34 Croqueteer Assigned To  => Croqueteer
01-06-05 18:34 Croqueteer Note Added: 0001006
01-06-05 18:34 Croqueteer Assigned To Croqueteer =>


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
51 total queries executed.
38 unique queries executed.
Powered by Mantis Bugtracker