Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000448 [Croquet] Jasmine major always 10-24-04 13:18 11-11-04 17:13
Reporter pheras View Status public  
Assigned To Croqueteer
Priority normal Resolution fixed  
Status resolved  
Summary 0000448: Multiuser error: user entering seaworld freezes the other
Description 2 users, one on Windows and one on MacOSX. Force tunneling option checked, LAN only option unchecked.

When one of them enters the seaworld (andrea's) the other user freezes, while the first one keeps alive.

See debug log attached.

Thanks.
Additional Information
Attached Files  SqueakDebug.log [^] (1,808 bytes) 10-24-04 13:18

- Relationships

- Notes
(0000526 - 264 - 267 - 267 - 267 - 267 - 267)
Croqueteer
10-26-04 05:04

I know this sounds odd, but try checking the date time of both systems and setting them to be as close as possible (<minute). We are aware of a bug that we believe is the same as this one, but don't have time to fix it right now (OOPSLA). Let us know your results.
 
(0000529 - 135 - 135 - 135 - 135 - 135 - 135)
pheras
10-27-04 03:18

I've synchronized to 1sec. The problem persists. I've tried too between a Linux machine and the MacOS and the problem is just the same.
 
(0000548 - 665 - 816 - 816 - 816 - 816 - 816)
mpm
10-28-04 01:54

There is soemthing funky right when you first cross the threshold of the portal
into the underwater world.

Tavatar>>RenderClear is being called, but there is no renderClear method for TAvatar,
and you get a DNU.

This appears to be happening because TCamera>>renderView is calling
       currentSpace renderClear: ogl.
    currentSpace renderSpace: ogl.

When you get the DNU, currentSpace is set to a TAvatar right as the avatar passes
through the portal into the fishworld. I think that can happen if the space the avatar is in
is nil. In that case the TFrame root method will
return the TAvatar as the root, instead of the space that we are expecting.
 
(0000665 - 149 - 149 - 149 - 149 - 149 - 149)
Croqueteer
11-11-04 17:13

The problem was we were switching to a shared avatar. We shouldn't have replaced the avatar in any case. Instead we replace the avatar's costume now.
 

- Issue History
Date Modified Username Field Change
10-24-04 13:18 pheras New Issue
10-24-04 13:18 pheras File Added: SqueakDebug.log
10-25-04 10:33 pheras Issue Monitored: pheras
10-26-04 05:04 Croqueteer Note Added: 0000526
10-27-04 03:18 pheras Note Added: 0000529
10-28-04 01:54 mpm Note Added: 0000548
11-11-04 17:13 Croqueteer Status new => resolved
11-11-04 17:13 Croqueteer Resolution open => fixed
11-11-04 17:13 Croqueteer Assigned To  => Croqueteer
11-11-04 17:13 Croqueteer Note Added: 0000665


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
52 total queries executed.
37 unique queries executed.
Powered by Mantis Bugtracker