Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000482 [Squeak 5.2] minor always 11-01-04 22:16 11-22-04 23:47
Reporter ned View Status public  
Assigned To ned
Priority normal Resolution fixed  
Status resolved  
Summary 0000482: Inappropriate events are displayed as choices for triggering scripts
Description Even though (for instance) non-Connector morphs will never receive #sourceConnected events, sourceConnected still shows up on the list of possible events with which to trigger a script.

The attached changeset fixes this problem, by having event registrants also specify which kinds of Morphs might receive the events.
Additional Information
Attached Files  SpecificEvents-nk.2.cs [^] (9,668 bytes) 11-01-04 22:16

- Relationships

- Notes
(0000578 - 213 - 231 - 231 - 231 - 231 - 231)
ned
11-01-04 22:34

Reminder sent to michael

Hi Michael,
This is a fix that I think is relatively important to avoid confusion because of the event triggering menu. What do you think of putting it into the Squeakland update stream?
 
(0000725 - 20 - 20 - 20 - 20 - 20 - 20)
ned
11-22-04 23:47

Fixed by attached CS
 

- Issue History
Date Modified Username Field Change
11-01-04 22:16 ned New Issue
11-01-04 22:16 ned File Added: SpecificEvents-nk.2.cs
11-01-04 22:33 ned Status new => feedback
11-01-04 22:34 ned Issue Monitored: michael
11-01-04 22:34 ned Note Added: 0000578
11-01-04 22:36 ned Status feedback => assigned
11-01-04 22:36 ned Assigned To  => ned
11-22-04 23:47 ned Status assigned => resolved
11-22-04 23:47 ned Resolution open => fixed
11-22-04 23:47 ned Note Added: 0000725


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
45 total queries executed.
32 unique queries executed.
Powered by Mantis Bugtracker