Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000512 [Croquet] Jasmine trivial sometimes 11-10-04 16:36 11-12-04 16:03
Reporter dfaught View Status public  
Assigned To Croqueteer
Priority normal Resolution fixed  
Status resolved  
Summary 0000512: Avatar orientation not righted after passing though portal
Description I built a portal pair between spaces where the window on one side is "normal" orientation, and the window on the other side is horizontal above the floor. When the avatar passes through starting from the "normal" orientation, it often falls to the floor on its head and stays there upside-down and very disoriented.
Additional Information This is in the version 4-5 of DualMaze on SqueakMap. Initially, go through the portal window on the right. You can "fly" around the maze to its bottom to get to the portal in question. I can build a simplified space to test with, if necessary.
Attached Files  selfRightTAvatar.1.cs.gz [^] (1,263 bytes) 11-12-04 06:54
 selfRightTAvatar.2.cs.gz [^] (1,260 bytes) 11-12-04 07:57

- Relationships

- Notes
(0000670 - 292 - 312 - 312 - 312 - 312 - 312)
dfaught
11-12-04 06:58

Okay, here's one solution. Basicly adds a "selfRighting" boolean instance variable to TAvatar with accessors, and then if it's true in #fall, multiplies both pitch and roll by 0.008. This makes the avatar behave slightly differently, especially when "looking around" with shift button down.
 
(0000671 - 87 - 87 - 87 - 87 - 87 - 87)
dfaught
11-12-04 08:00

Oops. First changeset conflicted with recent FishAvatar change. Second one fixes that.
 
(0000674 - 104 - 104 - 104 - 104 - 104 - 104)
andreas
11-12-04 08:44

DAS needs to check this - the portal math is all his and I won't interfere with it if I can avoid it ;-)
 
(0000677 - 142 - 152 - 152 - 152 - 152 - 152)
dfaught
11-12-04 15:44

I'm wondering if this might interfere with, or maybe improve, Impara's "Project Magrathea", or if they manage their changes separately anyway.
 
(0000678 - 429 - 429 - 429 - 429 - 429 - 429)
Croqueteer
11-12-04 16:03

The problem is that the avatar allows for a roll (as in roll pitch yaw). Pitch and Yaw are OK - in fact necessary, but roll should always be 0. This guarantees it to be 0. The real thing to do at some point is to have the space specify a context specific down vector. What this means is the avatar should query the space for down, and attempt to match it. This makes it easier to do the walk around sphere or torus or whatever...
 

- Issue History
Date Modified Username Field Change
11-10-04 16:36 dfaught New Issue
11-12-04 06:54 dfaught File Added: selfRightTAvatar.1.cs.gz
11-12-04 06:58 dfaught Note Added: 0000670
11-12-04 07:57 dfaught File Added: selfRightTAvatar.2.cs.gz
11-12-04 08:00 dfaught Note Added: 0000671
11-12-04 08:44 andreas Note Added: 0000674
11-12-04 08:44 andreas Assigned To  => Croqueteer
11-12-04 08:44 andreas Status new => assigned
11-12-04 15:44 dfaught Note Added: 0000677
11-12-04 16:03 Croqueteer Status assigned => resolved
11-12-04 16:03 Croqueteer Resolution open => fixed
11-12-04 16:03 Croqueteer Note Added: 0000678


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
57 total queries executed.
39 unique queries executed.
Powered by Mantis Bugtracker