Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000554 [Croquet] Jasmine major always 11-23-04 21:02 12-08-04 05:18
Reporter mpm View Status public  
Assigned To
Priority normal Resolution fixed  
Status resolved  
Summary 0000554: Mulituser: Alice avatar texture is black except for right sholder
Description Proobably fallout from the latest texture/TFrom changes. In the SamepleTeapot, the Alice avatar's textures turns black (except the right sholder) as soon as another user joins the party. Its a kinda cool visual effect, but not what we really want long term.
Additional Information
Attached Files

- Relationships

- Notes
(0000763 - 181 - 181 - 181 - 181 - 181 - 181)
dfaught
11-26-04 20:51

I saw something like this too, but I thought at the time that it was because both of the two users were standing in the same place, causing the Alices to be overlaid in the display.
 
(0000774 - 371 - 429 - 429 - 429 - 429 - 429)
elenzil
11-29-04 21:40

typically in 3D graphics,
exactly overlayed objects don't appear black,
they appear sort of flickery & interferency,
sometimes with moire patterns.
they may have other appearances,
but changing to a color (eg black) which is present
in neither object would be a surprising one.

in any case,
i'm seeing this bug as well with latest updates on 20041129 in the AM.
 
(0000878 - 644 - 666 - 666 - 666 - 666 - 666)
andreas
12-08-04 05:18

The problem should be fixed for now though the solution isn't complete. What will happen is that if we load a multitude of .tea files (like avatars) each of those WILL indeed get a copy of the texture. I cannot fix this problem properly since the TForms remember "up pointers" to their owning textures and the problem is caused by an asymmetry in reading and writing the textures vs. the tform referenced (if you don't understand this don't worry - I am writing this in case I ever wonder why I did what I did).

This ought to be fixed properly once we are able to deal with TForms as resources which are held by (semi-)immutable tea parties.
 

- Issue History
Date Modified Username Field Change
11-23-04 21:02 mpm New Issue
11-26-04 20:51 dfaught Note Added: 0000763
11-29-04 21:40 elenzil Note Added: 0000774
12-08-04 05:18 andreas Note Added: 0000878
12-08-04 05:18 andreas Status new => resolved
12-08-04 05:18 andreas Resolution open => fixed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
44 total queries executed.
35 unique queries executed.
Powered by Mantis Bugtracker