Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000579 [Croquet] Jasmine minor always 12-01-04 21:33 12-02-04 23:01
Reporter elenzil View Status public  
Assigned To
Priority normal Resolution fixed  
Status resolved  
Summary 0000579: rotationAround<Axis> cannot be followed by another rotationAround<A Different Axis>
Description The following code results in a 45 degree solid rhomboid.
See attached screenshot.

cube _ TCube new.
space addChild: cube.
cube rotationAroundX: 90.
cube rotationAroundY: 0.
Additional Information
Attached Files  transformweirdness.png [^] (101,726 bytes) 12-01-04 21:33

- Relationships

- Notes
(0000809 - 89 - 101 - 101 - 101 - 101 - 101)
Croqueteer
12-02-04 21:38

This is not a bug.

Use #addRotationAroundX: (or y,z) when you need to do this instead.
 
(0000814 - 238 - 268 - 268 - 268 - 268 - 268)
elenzil
12-02-04 22:12

perhaps then this could be added to the top of the rotationAround<Axis> calls:
self orientation: B3DMatrix4x4 identity.

i think most folks would expect the code above to result in some sort of rotation
rather than a skew deformation.
 
(0000817 - 80 - 80 - 80 - 80 - 80 - 80)
Croqueteer
12-02-04 23:01

OK. It now sets the transform to the identity and applies this transform on top.
 

- Issue History
Date Modified Username Field Change
12-01-04 21:33 elenzil New Issue
12-01-04 21:33 elenzil File Added: transformweirdness.png
12-02-04 21:38 Croqueteer Status new => closed
12-02-04 21:38 Croqueteer Note Added: 0000809
12-02-04 22:12 elenzil Status closed => feedback
12-02-04 22:12 elenzil Resolution open => reopened
12-02-04 22:12 elenzil Note Added: 0000814
12-02-04 22:12 elenzil Resolution reopened => open
12-02-04 23:01 Croqueteer Status feedback => resolved
12-02-04 23:01 Croqueteer Resolution open => fixed
12-02-04 23:01 Croqueteer Assigned To  => Croqueteer
12-02-04 23:01 Croqueteer Note Added: 0000817
12-02-04 23:01 Croqueteer Assigned To Croqueteer =>


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
50 total queries executed.
34 unique queries executed.
Powered by Mantis Bugtracker