Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006419 [Squeak] Tools minor always 04-13-07 18:07 07-04-08 01:31
Reporter black View Status public  
Assigned To
Priority normal Resolution duplicate  
Status closed   Product Version 3.9
Summary 0006419: The Selector Browser/ Method Finder is schizophrenic
Description Is it the "selector browser" or the "method finder"? The name of the implementing class, the name in the title of the tool, the name in the flap and the name in the open menu should all be the same!
Additional Information There should perhaps be a conention that each tool has a #name method to avoid this problem in future; selector browser is not the only example. Is it the "System Browser" or the "Class Browser" or the "Browser"?
If we rename the classes consistently, then instead of stroing allof these random and divergent strings, we could just use

    ToolClass name withSpaces

where wothSpaces is a new method on Strings that understands CamelCase and turns #ToolClass into 'Tool Class'

SelectorBrowser class should probably be renamed MethodFinder, and

    SelectorBrowser class prototypicalToolWindow and
    Utilities class addSampleWindowsTo:

be edited to use the right name.
Attached Files

- Relationships
duplicate of 0005676new  Method Finder suffers from mistaken identity 
child of 0007110new  Mother of Method Finder issues 

There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
04-13-07 18:07 black New Issue
04-14-07 03:09 wiz Relationship added related to 0006417
04-14-07 03:10 wiz Relationship added related to 0006418
07-04-08 01:24 matthewf Relationship added child of 0007110
07-04-08 01:31 matthewf Relationship added duplicate of 0005676
07-04-08 01:31 matthewf Status new => closed
07-04-08 01:31 matthewf Resolution open => duplicate
07-04-08 01:35 matthewf Relationship deleted related to 0006418
07-04-08 01:42 matthewf Relationship deleted related to 0006417


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
48 total queries executed.
32 unique queries executed.
Powered by Mantis Bugtracker