Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000692 [Squeak 5.2] Morphic feature always 12-18-04 04:41 03-09-05 19:50
Reporter wiz View Status public  
Assigned To
Priority normal Resolution open  
Status resolved  
Summary 0000692: Saving project will also save the contents of the trash (no warning given)
Description Get a fresh project.
Grab a rectangle.
Save the project.
With the halo on the rectangle press the recolor handle.

Now throw the property sheet away by invoking its halo and pressing its delete buttton.
Now save the project.
The project is now several times bigger due to its preservation of the garbage.

There is NO warning that it is saving the property sheet. And this IMHO will not be in the general case what the user intended.

Additional Information So when it is about to do that it should at least ask if it is desired.
Attached Files

- Relationships

- Notes
(0001071 - 356 - 356 - 356 - 356 - 356 - 356)
wiz
01-13-05 08:32

Hmm. I'm not sure I've described the problem properly. What I have noticed is sometimes small projects have saved to big files. What all is being saved with them I am not sure. It would be helpful if someone had a way to see inside a project and enumerate its contents w/o commiting to loading it into squeak. Does anyone know where to find such a thing?
 
(0001241 - 167 - 167 - 167 - 167 - 167 - 167)
ned
03-09-05 19:50

After some discussion with the Squeakland devteam, it was decided (Mar. 9 2005) that we'd leave the current behavior for now, and try not to make this happen in Tweak.
 

- Issue History
Date Modified Username Field Change
12-18-04 04:41 wiz New Issue
01-07-05 20:13 bert Project Squeak => Squeak 5.2
01-13-05 08:32 wiz Note Added: 0001071
03-09-05 19:50 ned Note Added: 0001241
03-09-05 19:50 ned Severity major => feature
03-09-05 19:50 ned Status new => resolved


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
40 total queries executed.
33 unique queries executed.
Powered by Mantis Bugtracker