Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000073 [tweak] major always 08-13-04 15:29 12-08-04 23:16
Reporter tedka View Status public  
Assigned To tedka
Priority normal Resolution open  
Status resolved  
Summary 0000073: CTextField shows no text if the text won't fit vertically
Description If the size of a CTextField is too small, the scroll bar appears in the middle of the field, and no text appears. If you make the field bigger, so that all of the text fits, it all shows.
This must be some special case about how the text field is embedded in the outer object, since this does not happen in CBrowser, etc.
Perhaps the inner scrollable pane is too narrow (its width is not tracking the width of the container?).
Additional Information (I will work up an example and insert the code into this bug report soon.)
Attached Files

- Relationships

- Notes
(0000136 - 822 - 947 - 947 - 947 - 947 - 947)
tedka
09-07-04 23:10

Andreas found that the problem is this: A CTextEditor does its own layout. Giving it a table layout causes this bug (odd scroll bars and no text). Setting its layout to be nil fixes everything.
      The tablelayout got there because my instance variable was originally another class of object which did want a table Layout. When I stored the CTextEditor there, the Costume did not get changed and kept the table layout.
      I will develop a message that asks a new Player whether it does its own layout, and nils the layout if it does. I will try to automatically get an object that does its own layout will nil the layout.
       Maybe the existance of a TableLayout should not cause CTextEditor to have convulsions. Is there a way for objects that do their own layout to simply ignore the layout?

--Ted.
 
(0000138 - 62 - 74 - 74 - 74 - 74 - 74)
tedka
09-07-04 23:17

Bug 070 is the same bug as this. I closed that bug.

--Ted.
 

- Issue History
Date Modified Username Field Change
08-13-04 15:29 tedka New Issue
09-07-04 23:01 tedka Status new => assigned
09-07-04 23:01 tedka Assigned To  => tedka
09-07-04 23:10 tedka Note Added: 0000136
09-07-04 23:17 tedka Note Added: 0000138
12-08-04 23:16 tedka Status assigned => resolved
12-08-04 23:16 tedka Description Updated


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
40 total queries executed.
30 unique queries executed.
Powered by Mantis Bugtracker