Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000785 [tweak] Any feature always 12-31-04 05:45 01-15-05 05:47
Reporter tim View Status public  
Assigned To
Priority low Resolution reopened  
Status feedback  
Summary 0000785: Scroll bars on right hand side of pane are a pain
Description Really, just what is the world coming to?
Additional Information
Attached Files

- Relationships

- Notes
(0001077 - 480 - 492 - 492 - 492 - 492 - 492)
tim
01-14-05 08:45

Oh, come on guys, let's at least allow scrollbars on the left as an option. It is, after all, where most of the text is most of the time. The mouse is fairly likely already to be near the left edge of a pane.

Now, I can see some (small) virtue in a right side scrollbar in a tablet/stylus type interface for right handed people - but it would be a nightmare for us lefthanders and you all know that we are over represented amongst the smart and wealthy. So, no pissing us off!
 
(0001078 - 631 - 643 - 643 - 643 - 643 - 643)
andreas
01-14-05 08:53

Tim - I can tell you right now and right here that noone is ever going to address this issue seriously unless there are major new arguments being put up (and I haven't seen any in the last twenty-five years). The fact of the matter is that ALL of the systems except Smalltalk-80 have scroll bars on the right (believe it or not) and so This. Is. What. We'll. Do.

If you feel bored you're welcome to add a preference or something alike which supports the scrollbar-on-left feature - to me this feels like a waste of valuable man power so don't expect this issue to be addressed any time soon. I have more pressing things at hand.
 
(0001081 - 251 - 263 - 263 - 263 - 263 - 263)
bert
01-14-05 14:09

Actually I think at least X11 (Xt, athena widgets, Motif) defaulted to left scrollbars, while more recent X environments (KDE, Gnome) default to right.

Anyway, I'll change this into a low-priority feature request. Anyone's welcome to implement it.
 
(0001082 - 200 - 200 - 200 - 200 - 200 - 200)
tim
01-14-05 20:55

I just know you can't actually believe that simply because many other UI system do scrollbars one way it must always be so - if you were that conformist you wouldn't be doing squeak, tweak or croquet.
 
(0001085 - 407 - 417 - 417 - 417 - 417 - 417)
andreas
01-15-05 05:47

Actually I do believe precisely what I said. Unless you have really good arguments the only thing you'll hear is "Eeek! The scroll bars are on the WRONG side!" and scrollbars and other standard widgets are certainly not at the focus of attention in Croquet or Tweak - we just need them. I like to pick my fights and that's not going to be one of them; if you feel like fixing this fine, if not, fine too ;-)
 

- Issue History
Date Modified Username Field Change
12-31-04 05:45 tim New Issue
01-13-05 09:05 andreas Status new => resolved
01-13-05 09:05 andreas Resolution open => won't fix
01-13-05 09:05 andreas Assigned To  => andreas
01-13-05 09:05 andreas Assigned To andreas =>
01-14-05 08:45 tim Status resolved => feedback
01-14-05 08:45 tim Resolution won't fix => reopened
01-14-05 08:45 tim Note Added: 0001077
01-14-05 08:53 andreas Note Added: 0001078
01-14-05 14:09 bert Note Added: 0001081
01-14-05 14:09 bert Priority normal => low
01-14-05 14:09 bert Severity major => feature
01-14-05 20:55 tim Note Added: 0001082
01-15-05 05:47 andreas Note Added: 0001085


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
57 total queries executed.
41 unique queries executed.
Powered by Mantis Bugtracker