Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000944 [tweak] Any major always 03-10-05 08:41 03-30-05 11:11
Reporter johnmci View Status public  
Assigned To
Priority normal Resolution fixed  
Status resolved  
Summary 0000944: drop non-graphics file from desktop on tweak project results in walkback
Description If the filestream mimeType cannot be decided on, ie no known mimetype, you get a walkback in Tweak because nil does not understand anySatisfy:. This also triggers a walkback in morphic because for some reason the lastMouseEvent in CRootMorph>>handleEvent: points to the DropFilesEvent instance and it doesn't understand the method buttons


 dropFile: fileStream
    "The given file was just dropped onto me"
    | types |
    types _ fileStream mimeTypes.
    (types anySatisfy:[:mimeType| mimeType beginsWith: 'image/']) ifTrue:[
        (self importImageFrom: fileStream) asPlayer openIn: self project at: self project cursorPoint.
    ].

Additional Information I'll note even if you drag a PNG to a tweak project window, which does invoke the importImageFrom: logic, you still get the morphic walkback on sending buttons to the DropFilesEvent
Attached Files

- Relationships

- Notes
(0001249 - 21 - 21 - 21 - 21 - 21 - 21)
johnmci
03-10-05 08:43

DNU on buttons is 880
 

- Issue History
Date Modified Username Field Change
03-10-05 08:41 johnmci New Issue
03-10-05 08:43 johnmci Note Added: 0001249
03-30-05 11:11 andreas Status new => resolved
03-30-05 11:11 andreas Resolution open => fixed
03-30-05 11:11 andreas Assigned To  => andreas
03-30-05 11:11 andreas Assigned To andreas =>


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
36 total queries executed.
30 unique queries executed.
Powered by Mantis Bugtracker