Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000956 [tweak] Any major always 03-11-05 13:08 03-31-05 22:19
Reporter jens View Status public  
Assigned To
Priority high Resolution fixed  
Status resolved  
Summary 0000956: Transcript loses information
Description transcript loses information if you use recursion and blocks.
but if you slow things with a 'self waitTick' down, it works as intendet.
The changeset demonstrates the bug.
Additional Information
Attached Files  TranscriptBug.1.cs [^] (662 bytes) 03-11-05 13:08

- Relationships

- Notes
(0001252 - 700 - 754 - 754 - 754 - 754 - 754)
jens
03-11-05 13:15

"Foo new foo" in workspace should show something like this in the Tweak Transcript:
 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124

if you uncomment "waitTick" in foo it shows:
 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124
 
(0001306 - 120 - 120 - 120 - 120 - 120 - 120)
michael
03-30-05 02:24

IMO this indicates some serious problem with event handling or coalescing of events. These writes should never get lost.
 
(0001308 - 582 - 621 - 621 - 621 - 621 - 621)
andreas
03-30-05 08:53

The bug was caused by an ancient and pretty arbitrary restriction for event buffers. Originally I had thought that limiting those buffers would give us space advantages - say if you have a loop such as
   1 to: 1000000 do:[:i| var := i].
then one million change events would be generated and need to be processed so being able to truncate the event chain can be advantageous. But the way this happened here is just totally bogus - it threw away events where it would have to do something smart (if anything).

The latest Scripting package on source.impara.de contains the fixes.
 
(0001328 - 168 - 204 - 204 - 204 - 204 - 204)
jens
03-31-05 13:23

Transcript loses information again.

Transcript show: 'foo'; show: 'bar'.

produces as output in the Transcript 'bar' and not 'foobar' as expected

(Tweak3.8)
 
(0001329 - 40 - 40 - 40 - 40 - 40 - 40)
andreas
03-31-05 22:18

Oops. Small typo, big effect. Now fixed.
 

- Issue History
Date Modified Username Field Change
03-11-05 13:08 jens New Issue
03-11-05 13:08 jens File Added: TranscriptBug.1.cs
03-11-05 13:15 jens Note Added: 0001252
03-30-05 02:24 michael Note Added: 0001306
03-30-05 02:24 michael Priority normal => high
03-30-05 02:24 michael Severity minor => major
03-30-05 08:53 andreas Status new => resolved
03-30-05 08:53 andreas Resolution open => fixed
03-30-05 08:53 andreas Assigned To  => andreas
03-30-05 08:53 andreas Note Added: 0001308
03-30-05 08:54 andreas Assigned To andreas =>
03-31-05 13:23 jens Status resolved => feedback
03-31-05 13:23 jens Resolution fixed => reopened
03-31-05 13:23 jens Note Added: 0001328
03-31-05 22:18 andreas Status feedback => resolved
03-31-05 22:18 andreas Resolution reopened => fixed
03-31-05 22:18 andreas Assigned To  => andreas
03-31-05 22:18 andreas Note Added: 0001329
03-31-05 22:19 andreas Assigned To andreas =>


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
63 total queries executed.
41 unique queries executed.
Powered by Mantis Bugtracker